INSN_SCOPE changes break mips-elf
Jan Hubicka
jh@suse.cz
Thu Jun 20 11:16:00 GMT 2002
> On Thu, Jun 20, 2002 at 08:04:23PM +0200, Jan Hubicka wrote:
> > combine_scopes is function to solve problem "I have instruction A with
> > scope X and B with scope Y, I am replacing them by one instruction,
> > create for me the scope combining X and Y in the best possible way"
>
> Yes, but it does not "combine" scopes at all. It chooses the
> most specific scope. There is no mechanism in any debug format
> to truely union the two scopes.
Right. I tought that as abstraction. Later some format may do it,
so in code I write what I want and combine_scope does it's best in
current implementation.
Do you have idea for better name/better implementation?
Honza
>
>
> r~
More information about the Gcc
mailing list