INSN_SCOPE changes break mips-elf

Jan Hubicka jh@suse.cz
Thu Jun 20 11:12:00 GMT 2002


> On Thu, Jun 20, 2002 at 08:00:24PM +0200, Jan Hubicka wrote:
> > Hmm, I hoped it will chosse the inner scope.  I've just copied it over
> > finalize_insn_scopes.
> > 
> > Do you have better idea how to combine the scopes then?  Simply choose
> > first one if non-null at the moment?
> 
> Walk the scope tree and pick the inner one?  At which point
> "combine_scopes" is a poor name.

combine_scopes is function to solve problem "I have instruction A with
scope X and B with scope Y, I am replacing them by one instruction,
create for me the scope combining X and Y in the best possible way"

Honza
> 
> 
> r~



More information about the Gcc mailing list