Analysis of solaris2 27_io/istream_extractor_arith.cc failures

Gabriel Dos Reis gdr@integrable-solutions.net
Thu Dec 26 19:16:00 GMT 2002


"Kaveh R. Ghazi" <ghazi@caip.rutgers.edu> writes:

[...]

| I'd like to chop out the particular code (test12) into a new file and
| xfail just that test.

I believe that is a sensible approach.

[...]

| Patch to follow after some testing.  Any suggestions for the name of
| the new split out file?  Using istream_extractor_arith2 didn't seem
| very descriptive.

Well, I'm not sure we will come up with a naming scheme that is
  a) sensical, i.e. descriptive;
  b) matches standard description. i.e. the paragraph in the Standard;
     specificationp;
  c) scalable;
  d) easy to use.

I suspect that, somehow, we will end up with numbers.  Therefore I
would suggest the testcases be named after the title of the
paragraphes that describe them in the C++ definition text.  I know
Benjamin is skeptical about numbering, so I would appreciate to have
his input on this suggestion.

-- Gaby



More information about the Gcc mailing list