Hi,
Is it all right to replace all tests of the
of the form
(REG_NO) < FIRST_PSEUDO_REGISTER
by
HARD_REGISTER_P (REG_NO) (defined in rtl.h already)
It would have two advantages
1. More readable.
2. If the perception of what a "hard reg" is changes in future
it would be easy to incorporate the semantics.
Best Regards,
Naveen Sharma.