Those pesky incomprehensible if statements

Mike Stump mrs@windriver.com
Tue Feb 20 01:29:00 GMT 2001


> From: "Zack Weinberg" <zackw@stanford.edu>
> Date: Mon, 19 Feb 2001 11:34:18 -0800
> To: gcc@gcc.gnu.org

>   if (match_p (set, '(set (stack_pointer_rtx) 
> 			  (plus (stack_pointer_rtx) (const_int)))))

> Isn't that so much easier to read?

Yes, Maude and prop do exactly this, it is a fairly standard
technique.  One day I hope that the source language that gcc is
written in will allow one to make use of this type of source language
in this type of context.



More information about the Gcc mailing list