Modes on CONST_INTs

Alexandre Oliva aoliva@redhat.com
Sun Nov 26 22:14:00 GMT 2000


On Nov 24, 2000, Bernd Schmidt <bernds@redhat.com> wrote:

> 1. Create a new macro GENMINT (MODE, INTVAL).  This macro will at first
>    ignore the MODE argument.
>    Replace all uses of GEN_INT with GENMINT.  Once done, remove the old
>    GEN_INT and rename GENMINT to GEN_INT.  (I'm open to suggestions for
>    a better name than GENMINT, but it should have 7 characters to avoid
>    reformatting madness).

How about G<MODE>_INT (INTVAL), to avoid reformatting madness.  For
each MODE (expressed as SI, HI, etc), G<MODE>_INT (VAL) would just
call GEN_INT (<MODE>mode, (VAL)).  The advantage of changing GEN_INT
so that it takes a pair of arguments is that the compiler would catch
old-style uses for you.

-- 
Alexandre Oliva   Enjoy Guarana', see http://www.ic.unicamp.br/~oliva/
Red Hat GCC Developer                  aoliva@{cygnus.com, redhat.com}
CS PhD student at IC-Unicamp        oliva@{lsd.ic.unicamp.br, gnu.org}
Free Software Evangelist    *Please* write to mailing lists, not to me


More information about the Gcc mailing list