Makefile change to restart bootstraps

Richard Kenner kenner@vlsi1.ultra.nyu.edu
Mon Nov 13 03:27:00 GMT 2000


    I strongly agree.  The new system relies *far* too heavily on stamp files 
    which are completely non-intuitive, since they bear no relation to what is 
    happening.  stage_[abcde] means nothing to me.

Although I'm having trouble visusalizing the details, I think it might be
possible to rename those files so they are actually in the stage directory,
thus the right thing happens move often in the presence of directory copies.

But I think I'm seeing a concensus this, although this might be useful
sometimes, it shouldn't be the default.

What do people thing about renaming this to "make restartable_bootstrap",
letting somebody else do the change above, and putting back the old
"bootstrap" targets?


More information about the Gcc mailing list