I think having the && implicit would be better: "condition" "reload_completed" The reason I don't like that is that it isn't obvious to the casual reader that the second condition is really the "&&" of the two of them.