Uninitialized variable warnings

Joern Rennecke amylaar@cygnus.co.uk
Wed Mar 31 23:46:00 GMT 1999


> I'm basically wondering if it would be safe to move the if(reg_equiv_mem[i])
> and if(reg_equiv_address[i]) blocks that set `addr' inside the
> if(reg_equiv_memory_loc[i]) block that sets is_scalar.  That wouldn't make
> gcc stop warning, but it would make it clearer to a human what's going on.

Yes, that would be safe.

However, I'm not so sure that it makes the code easier to read -
if you don't know what reg_equiv_memory_loc / reg_equiv_address /
reg_equiv_mem are, you're pretty much lost anyways.

Besides, their meaning is explained at the definition of reg_equiv_memory_loc.



More information about the Gcc mailing list