Successfully build of egcs 1.1.2 on AIX 4.3.2.0

Chris Norton chris@dmdata.com
Wed Jun 23 14:05:00 GMT 1999


I have just finished successfully building and installing egcs 1.1.2 on
my RS/6000 model F50 (dual processor - 332 MHz)
As your web site requests, here is the output of config.guess
[eng43](root)/tools/egcs_obj> /tools/egcs-1.1.2/config.guess
powerpc-ibm-aix4.3.2.0
[eng43](root)/tools/egcs_obj> oslevel
4.3.2.0
I was able to build 1.1.2 using a pre compiled binary of egcs 1.1.1.1
that I found at  http://www-frec.bull.com/
which had been packaged for AIX 4.1.5 on 9-DEC-98
My sincere thanks for posting the info concerning the lack of AIX 4.3
support in GNU binutils 2.9.  Until I read this, I had tried to configure
egcs to use the GNU as and ld.  Further, I had no success using binutils
2.9.1 as I encountered ranlib problems.  I used GNU make version is
3.7.7  Lastly, I was able to leverage both processors using `make
bootstrap MAKE="make -j 2" -j 2'  (Sorry, I didn't track the build
time so I can't provide any performance benchmarks)
The entire build process went very smoothly!  I was pleasantly
surprised to find that I did not have to manually fix anything.
Chris Norton
Senior Systems Analyst/Programmer



More information about the Gcc mailing list