unsuccessful installation of egcs-1.1.1 (can't find cc1plus)

Steinar Bang sb@metis.no
Thu Jan 21 04:35:00 GMT 1999


>>>>> Steinar Bang <sb@metis.no>:

> Platform: linux S.u.S.E. 5.3
> I don't get it!  Two weeks ago I successfully installed egcs-1.1.1 on
> this very same machine, using
> 	./configure --prefix=~/apps --enable-shared

> That installation had problems linking some (not all) shared libs, so
> I wanted to install egcs without the --enable-shared configuration
> option, ie. configured with
> 	./configure --prefix=~/apps

> However this time I was unsuccessful in getting a working installation.
> I'm getting messages like this:
> 	g++ -c -pipe -g -fPIC -DANTLRCommonTokenTEXTSIZE=1024 -DQT_FATAL_ASSERT -I/home/sb/2x/include -I/home/sb/2x/3rdparty/pccts/sorcerer/h -I/home/sb/2x/3rdparty/pccts/h -o .obj/debug/mmlAst.o mmlAst.cpp
> 	g++: installation problem, cannot exec `cc1plus': No such file or directory
> 	mmlAst.cpp:28: iostream: No such file or directory
> 	cpp: output pipe has been closed

This isn't the obvious one that I'm running the g++ installed by the
system, because the system's 2.7.2.1 installation doesn't *have* a g++ 
installed, and besides, "which g++" gives me the following answer:
	> which gcc
	/home/sb/apps/bin/gcc

Hm... I'm installing from the exact same tar.gz file I got a
successful installation from earlier.  It successfully does a 3 stage
bootstrap and it seems to install all the correct files in all the
expected places.

The most probable thing is that something has changed in my
installation... but what on earth could it be...?

I'm stumped!



More information about the Gcc mailing list