egcs compile problems on R.H 5.0 (alpha) again

Gavin Woodhatch
Fri Sep 11 04:04:00 GMT 1998

Hi ,

Please reply to my email as i am not on the egcs mailing list .. (yet ?)

Well after fiddeling around for a while .. and a good 20 min compiling ..
the same error turned up ..
*sigh* .. so some bit of my R.H 5.0 installation must be confusing egcs ..
I have binutils 2.9.1

So the question is .. what is different with my setup .. as it does not work

Regards Gavin

PS I tried commenting out the #include <signal.h> but that caused more
errors ..

here is the error msg again

make[1]: Entering directory `/home/usr/egcs-1.1b/gcc'
gcc  -DIN_GCC    -g -O2  -DHAVE_CONFIG_H -DHAIFA    -I. -I. -I./config  \
-DTARGET_MACHINE=\"alphaev5-unknown-linux-gnu\"  \
-c `echo ./collect2.c | sed 's,^\./,,'`
collect2.c:191: conflicting types for `sys_siglist'
/usr/include/signal.h:237: previous declaration of `sys_siglist'
make[1]: *** [collect2.o] Error 1
make[1]: Leaving directory `/home/usr/egcs-1.1b/gcc'
make: *** [all-gcc] Error 2
[root@sigi egcs-1.1b]#

More information about the Gcc mailing list