_G_config.h not picking up sigset.h on linux 2.0.35 + glibc 2.0.7 (RH5.1)

Tkil tkil@scrye.com
Thu Sep 10 07:57:00 GMT 1998


I've been having this problem for a while (everything past 1.0
release).  I noticed that similar problems were reported about a year
ago:

   http://www.cygnus.com/ml/egcs-bugs/1997-Sep/0159.html

Jeff indicated at the time that some progress was being made -- Jeff,
do you happen to remember the status of that?

It's entirely possible that something on my machine is hozed, it's
been through quite a few combinations of manual upgrade + root
partition shifting and all that fun stuff.

If you would like more information on my system, please just ask.

config.status in my build dir says:

../egcs-1.1b/configure --with-gcc-version-trigger=/usr/local/src/egcs-dir/egcs-1.1b/gcc/version.c --host=i586-pc-linux-gnulibc2 --prefix=/usr/local --enable-threads --norecursion 

and the actual error:

make[2]: Entering directory `/usr/local/src/egcs-dir/reptile-1.1b/i586-pc-linux-gnulibc2/libio'
if [ x"no" = xyes ] && [ ! -d pic ]; then \
  mkdir pic; \
else true; fi
touch stamp-picdir
rootme=`pwd`/ ; export rootme; \
CC="/usr/local/src/egcs-dir/reptile-1.1b/gcc/xgcc -B/usr/local/src/egcs-dir/reptile-1.1b/gcc/ -I. -I../../../egcs-1.1b/libio"; export CC; \
CXX="/usr/local/src/egcs-dir/reptile-1.1b/gcc/xgcc -B/usr/local/src/egcs-dir/reptile-1.1b/gcc/ -I. -I../../../egcs-1.1b/libio -nostdinc++ -nostdinc++ -g -O2"; export CXX; \
CONFIG_NM="nm"; export CONFIG_NM; \
/bin/sh ../../../egcs-1.1b/libio/gen-params LIB_VERSION=2.8.0  >tmp-params.h
mv tmp-params.h _G_config.h
test x"no" != xyes ||\
  /usr/local/src/egcs-dir/reptile-1.1b/gcc/xgcc -B/usr/local/src/egcs-dir/reptile-1.1b/gcc/ -c -g -O2 -I. -I../../../egcs-1.1b/libio   ../../../egcs-1.1b/libio/filedoalloc.c -o pic/filedoalloc.o
/usr/local/src/egcs-dir/reptile-1.1b/gcc/xgcc -B/usr/local/src/egcs-dir/reptile-1.1b/gcc/ -c -g -O2 -I. -I../../../egcs-1.1b/libio  ../../../egcs-1.1b/libio/filedoalloc.c
In file included from ../../../egcs-1.1b/libio/libio.h:30,
                 from ../../../egcs-1.1b/libio/iolibio.h:1,
                 from ../../../egcs-1.1b/libio/libioP.h:40,
                 from ../../../egcs-1.1b/libio/filedoalloc.c:48:
_G_config.h:45: parse error before `_G_sigset_t'
_G_config.h:45: warning: data definition has no type or storage class
make[2]: *** [filedoalloc.o] Error 1
make[2]: Leaving directory `/usr/local/src/egcs-dir/reptile-1.1b/i586-pc-linux-gnulibc2/libio'
make[1]: *** [all-target-libio] Error 2
make[1]: Leaving directory `/usr/local/src/egcs-dir/reptile-1.1b'
make: *** [bootstrap] Error 2
[tkil@reptile reptile-1.1b]$ 



More information about the Gcc mailing list