Compileing egcs-1.1b under AIX 4.1.5 fails

Adrian Phillips a.phillips@dnmi.no
Wed Sep 9 05:52:00 GMT 1998


>>>>> "Matthias" == Matthias Mueller <matthias@ica1.uni-stuttgart.de> writes:

    Matthias> Are you sure you made a "make bootstrap"? It should set
    Matthias> the required bigtoc flag for the linker. It may also be
    Matthias> necessary to apply the following PTF: I have just
    Matthias> discovered that an update to the AIX linker was released
    Matthias> in mid-March specifically to address the failure
    Matthias> encountered by GCC when using -bbigtoc linker option.  I
    Matthias> tested it this morning and it solves the failure on an
    Matthias> AIX 4.1.5 system that I was able to use.
 
    Matthias>         The update is PTF U455193 for APAR IX75823
    Matthias> available from service.boulder.ibm.com.

    Matthias> I just installed egcs 1.1 on AIX 4.1.5 and it worked
    Matthias> perfectly.
 
Yup, I forgot make bootstrap - out of habit as most GNU configure
software is ./configure; make; make test/check/install. In fact many a
time I've installed agcs using make (without bootstrap), again because
I forget.

Thanks for the help though,

Adrian



More information about the Gcc mailing list