egcs-1.1b (i586-pc-linux-gnulibc1): no ld?

Jim Knoble jmknoble@pobox.com
Mon Sep 7 03:15:00 GMT 1998


[I'm not subscribed to the list; please Cc me on replies.  Thanks.]

I've just been attempting to build egcs-1.1b on an
i586-pc-linux-gnulibc1 system (Red Hat Linux 4.2 with current errata
plus other fun stuff), and i'm coming up with a discrepancy between
egcs-1.1b and egcs-1.0.3a which i'm not able to resolve with the NEWS
and ChangeLog files, the FAQ, or the mailing list archives.

egcs-1.0.3a installed an `ld' binary as
.../gcc-lib/i586-pc-linux-gnulibc1/egcs-2.90.29/ld.  egcs-1.1b doesn't
appear to install a corresponding ld binary.  I built egcs-1.1b using:

    ../egcs-1.1b/configure --prefix=/usr \
        --program-transform-name='s~gcc~egcs~g' \
	--enable-shared
    make bootstrap CFLAGS="-O2 -mpentium -fno-strength-reduce"

Am i missing something?  Did `collect2' replace `ld' in the
.../egcs-2.91.57/ directory?  If not, do i need the ld binary?

Thanks for any help.

--jim

%%%%%%%%%%%%%%% jim knoble %%%%%%%% jmknoble@pobox.com %%%%%%%%%%%%%%%%%



More information about the Gcc mailing list