compiling error for gdb-4.17 using egcs-1.1b

Pinwu Xu pxu@perigee.net
Sun Sep 6 18:57:00 GMT 1998


Hi there,
   I ran into the following error compiling gdb-4.17 using egcs-1.1b,
here I tried to compile it with glibc2.0.7pre6, which was installed
in /usr/i486-linuxglibc2 as a second library, the egcs-1.1b is 
compiled with target i486-pc-linux-glibc1. 
   I was able to compile gdb-4.17 with egcs-1.0.x, secondary glibc2.06!
   The error message gives:

gcc -b i486-linuxglibc2 -c -nostdinc -I/usr/i486-linuxglibc2/include
-I/usr/lib/gcc-lib/i486-linuxglibc2/egcs-2.91.57/include -D__USE_MISC
-I. -I. -I./config -DHAVE_CONFIG_H -I./../include/opcode -I./../readline
-I../bfd -I./../bfd  -I./../include  infptrace.c
infptrace.c: In function `attach':
infptrace.c:206: `PTRACE_ATTACH' undeclared (first use in this function)
infptrace.c:206: (Each undeclared identifier is reported only once
infptrace.c:206: for each function it appears in.)
infptrace.c: In function `detach':
infptrace.c:222: `PTRACE_DETACH' undeclared (first use in this function)
make[1]: *** [infptrace.o] Error 1
make[1]: Leaving directory `/home/pxu/tmp/gdb-4.17/gdb'
make: *** [all-gdb] Error 2

>grep -n PTRACE_ATTACH *

infptrace.c:74:#define PT_ATTACH PTRACE_ATTACH
remote-vx.c:1242:  status = net_ptrace_clnt_call (PTRACE_ATTACH,
&ptrace_in, &ptrace_out);
umax-xdep.c:32:#define PTRACE_ATTACH PT_ATTACH

>ls -l umax-xdep.c infptrace.c
-rw-r--r--   1 pxu      users       15034 Feb  6  1998 infptrace.c
-rw-r--r--   1 pxu      users        3588 Nov  5  1995 umax-xdep.c

Help would be highly appreciated.

Pinwu

=====================================================================
| Pinwu Xu                                                          | 
|                                                                   |
| 313 Arrowhead Dr. #N         email: pxu@perigee.net               |
| Charlotte, NC 28213                 pinwu_xu@hotmail.com          |
| 704-921-0438(H)              http://www.eng.ua.edu/~pxu           |
| 704-594-2014(O)              http://www.perigee.net/~pxu          |
=====================================================================
 




More information about the Gcc mailing list