Instead of if (JUMP_TABLES_IN_TEXT_SECTION #if !defined(READONLY_DATA_SECTION) || 1 #endif ) the following would be shorter and easier to read: #if defined(READONLY_DATA_SECTION) if (JUMP_TABLES_IN_TEXT_SECTION) #endif