Compiling under UnixWare 2.1

Robert Lipe robertl@dgii.com
Mon Sep 15 08:31:00 GMT 1997


I should disclaim that I haven't actually tried egcs on UW 2.1, but the
OpenServer DS is licensed from the USL/Univel compilers, headers, and 
libraries, there is enough genetic similarity to make a discussion 
plausable.  

Oh, and my knowledge of fortan is that I read one book on it 15 years 
ago, so if one of the f77 folks tells you anything different, listen to
them and not me.


> I have tried to build egcs under UnixWare 2.1 - I get the  following fail
> 
> /usr/tools/src/egcs-970910/gcc/xgcc -B/usr/tools/src/egcs-970910/gcc/ -c -DSkip_f2c_Undefs -DAllow_TYQUAD -I. -I/usr/tools/src/egcs-970910/gcc/f/runtime/libI77 -I../../../include  -DSTDC_HEADERS=1 -D_POSIX_SOURCE=1 -DRETSIGTYPE=void -DNON_ANSI_RW_MODES=1 -DNO_EOF_CHAR_CHECK=1 -DSkip_f2c_Undefs=1 -DPad_UDread=1 -DWANT_LEAD_0=1  -g -O2 -g0 wrtfmt.c
> wrtfmt.c: In function `mv_cur':
> wrtfmt.c:48: structure has no member named `_ptr'
> wrtfmt.c:48: structure has no member named `_flag'

I looked at the generated Makefile in f/runtime/libI77 on my system, and
I have "-DMISSING_FILE_ELEMS=1" in the 'DEFS=' line.    This would turn
off the offending code on your system, I think.


If adding this does indeed cure it (ick) you need to look in 
f/runtime/configure and f/runtime/libI77/Makefile.in and 
determine why this didn't get set on your system.   f/runtime/configure.log
may offer some interesting clues.

RJL



More information about the Gcc mailing list