debug_reload output
Christian Iseli
chris@lslsun.epfl.ch
Tue Oct 14 12:55:00 GMT 1997
> From amylaar@cygnus.co.uk Tue Oct 14 17:20 MET 1997
> From: Joern Rennecke <amylaar@cygnus.co.uk>
> Subject: Re: debug_reload output
> To: chris@lslsun.epfl.ch (Christian Iseli)
> >
> > Hi,
> >
> > I would like to be able to redirect the output of de debug_reload routine
> > to something else than stderr, e.g., the greg dump file...
>
> That would be a considerable nuisance - instead of
> call debug_reload()
> you'd have to type
> call debug_reload(stderr)
> all the time in gdb - and if you forget it just once, the debugged
> process will crash and you have to start it all over again.
> If you must have a function that is like debug_reload but accepts an
> output stream as parameter, I'd prefer if you call it something else
> and have debug_reload calling it.
Ok, then how about having a global variable debug_reload_stream initialized
to stderr, instead of the parameter? Does this sound like a better proposition?
Christian
More information about the Gcc
mailing list