GCC build failure, HEAD@177250 on native

GCC regression tester regress@geoffk.org
Wed Aug 3 09:43:00 GMT 2011


With your recent patch, GCC HEAD revision 177250 had problems on:
native: build (about the same as the previous build)
Attached is build output for those targets.
The previous build was of revision 177247.

Log information for changes since the last build:
------------------------------------------------------------------------
r177248 | charlet | 2011-08-03 02:36:24 -0700 (Wed, 03 Aug 2011) | 8 lines
Changed paths:
   M /trunk/gcc/ada/ChangeLog
   M /trunk/gcc/ada/clean.adb
   M /trunk/gcc/ada/gnatcmd.adb
   M /trunk/gcc/ada/make.adb
   M /trunk/gcc/ada/prj-conf.adb
   M /trunk/gcc/ada/prj-conf.ads
   M /trunk/gcc/ada/prj-makr.adb
   M /trunk/gcc/ada/prj-pars.adb
   M /trunk/gcc/ada/prj-pars.ads
   M /trunk/gcc/ada/prj-part.adb
   M /trunk/gcc/ada/prj-part.ads
   M /trunk/gcc/ada/prj-proc.adb
   M /trunk/gcc/ada/prj-proc.ads
   M /trunk/gcc/ada/prj-tree.adb
   M /trunk/gcc/ada/prj-tree.ads
   M /trunk/gcc/ada/switch-m.adb
   M /trunk/gcc/ada/switch-m.ads

2011-08-03  Emmanuel Briot  <briot@adacore.com>

	* gnatcmd.adb, prj-proc.adb, prj-proc.ads, make.adb, prj-part.adb,
	prj-part.ads, switch-m.adb, switch-m.ads, prj-makr.adb, clean.adb,
	prj-pars.adb, prj-pars.ads, prj-conf.adb, prj-conf.ads, prj-tree.adb,
	prj-tree.ads (Prj.Tree.Environment): new type.


------------------------------------------------------------------------
r177250 | charlet | 2011-08-03 02:38:56 -0700 (Wed, 03 Aug 2011) | 13 lines
Changed paths:
   M /trunk/gcc/ada/ChangeLog
   M /trunk/gcc/ada/makeutl.adb
   M /trunk/gcc/ada/makeutl.ads
   M /trunk/gcc/ada/prj-attr.adb
   M /trunk/gcc/ada/prj-attr.ads
   M /trunk/gcc/ada/prj-proc.adb

2011-08-03  Emmanuel Briot  <briot@adacore.com>

	* prj-proc.adb, prj-attr.adb, prj-attr.ads (Get_Attribute_Index): do
	not systematically lower case attribute indexes that contain no "."
	Fix definition of several Naming attributes, which take
	a unit name as index and therefore should be case insensitive.
	Minor refactoring (reduce length of variable names).

2011-08-03  Emmanuel Briot  <briot@adacore.com>

	* makeutl.adb, makeutl.ads (Get_Switches): new subprogram.


------------------------------------------------------------------------

For more information, see <http://glutton.geoffk.org/HEAD/>.

-------------- next part --------------
	    -e 's/\([ABCDEFGHIJKLMNOPQRSTUVWXYZ_]*USE_WEAK\)/_GLIBCXX_\1/g' \
	    < /home/regress/tbox/svn-gcc/libstdc++-v3/../gcc/gthr-posix.h > i686-pc-linux-gnu/bits/gthr-posix.h
sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
	    -e 's/\(GCC[ABCDEFGHIJKLMNOPQRSTUVWXYZ_]*_H\)/_GLIBCXX_\1/g' \
	    -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
	    -e 's/\([ABCDEFGHIJKLMNOPQRSTUVWXYZ_]*USE_WEAK\)/_GLIBCXX_\1/g' \
	    < /home/regress/tbox/svn-gcc/libstdc++-v3/../gcc/gthr-tpf.h > i686-pc-linux-gnu/bits/gthr-tpf.h
sed -e 's/\(UNUSED\)/_GLIBCXX_\1/g' \
	    -e 's/\(GCC[ABCDEFGHIJKLMNOPQRSTUVWXYZ_]*_H\)/_GLIBCXX_\1/g' \
	    -e 's/SUPPORTS_WEAK/__GXX_WEAK__/g' \
	    -e 's/\([ABCDEFGHIJKLMNOPQRSTUVWXYZ_]*USE_WEAK\)/_GLIBCXX_\1/g' \
	    -e 's,^#include "\(.*\)",#include <bits/\1>,g' \
	    < /home/regress/tbox/svn-gcc/libstdc++-v3/../gcc/gthr-posix.h > i686-pc-linux-gnu/bits/gthr-default.h
make[3]: Leaving directory `/home/regress/tbox/native/build/i686-pc-linux-gnu/libstdc++-v3/include'
make[2]: Leaving directory `/home/regress/tbox/native/build'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/home/regress/tbox/native/build'
make: *** [bootstrap] Error 2
+ '[' -s .bad_compare ']'
+ exit 1
-------------- next part --------------

-- 
Geoffrey Keating <geoffk@geoffk.org> 
(via an automated GCC regression-testing script.)


More information about the Gcc-regression mailing list