1 GCC regressions, 0 new, with your patch on 2004-01-06T03:05:07Z.

GCC regression checker geoffk@apple.com
Tue Jan 6 10:33:00 GMT 2004


With your recent patch, GCC has some regression test failures, which
used to pass.  There are 0 new failures, and 1
failures that existed before and after that patch; 0 failures
have been fixed.

The old failures, which were not fixed or introduced by your patch, are:
native gcc.sum gcc.dg/20031201-1.c

For more information, see http://gcc.gnu.org/regtest/.
-------------- next part --------------
ChangeLog entries since last run on 2004-01-05T19:35:32Z:
--- /Users/regress/tbox/changelog_mail/gcc/gcc/ChangeLog	Mon Jan  5 11:36:29 2004
+++ gcc/gcc/ChangeLog	Mon Jan  5 19:06:58 2004
@@ -1,3 +1,9 @@
+2004-01-05  Kazu Hirata  <kazu@cs.umass.edu>
+
+	* system.h (ASM_OUTPUT_MAIN_SOURCE_FILENAME): Poison.
+	* toplev.c (output_file_directive): Don't use
+	ASM_OUTPUT_MAIN_SOURCE_FILENAME.
+
 2004-01-05  Daniel Berlin  <dberlin@dberlin.org>
 	
 	* ggc-zone.c: Remove everything in #ifdef USING_MALLOC_PAGE_GROUPS
--- /Users/regress/tbox/changelog_mail/gcc/gcc/cp/ChangeLog	Mon Jan  5 04:07:32 2004
+++ gcc/gcc/cp/ChangeLog	Mon Jan  5 19:07:02 2004
@@ -1,3 +1,22 @@
+2004-01-05  Mark Mitchell  <mark@codesourcery.com>
+
+	PR c++/13057
+	* class.c (build_clone): Copy type attributes from the original
+	function to the clone.
+	
+	PR c++/12815
+	* class.c (build_vtbl_ref_1): Do not unconditionally mark vtable
+	references as constant.
+
+	PR c++/12132
+	* parser.c (cp_parser_explicit_instantiation): Improve error
+	recovery.
+	(cp_parser_require): Improve indication of the error location.
+
+	PR c++/13451
+	* parser.c (cp_parser_class_head): Reorder logic to check for
+	invalid qualification.
+
 2004-01-04  Mark Mitchell  <mark@codesourcery.com>
 
 	PR c++/13157
--- /Users/regress/tbox/changelog_mail/gcc/gcc/testsuite/ChangeLog	Mon Jan  5 04:07:36 2004
+++ gcc/gcc/testsuite/ChangeLog	Mon Jan  5 19:07:09 2004
@@ -1,3 +1,20 @@
+2004-01-05  Mark Mitchell  <mark@codesourcery.com>
+
+	PR c++/12815
+	* g++.dg/rtti/typeid4.C: New test.
+
+2004-01-05  Eric Botcazou  <ebotcazou@libertysurf.fr>
+
+	* gcc.dg/compat/sdata-section.h: Declare 'abort'.
+
+2004-01-05  Mark Mitchell  <mark@codesourcery.com>
+
+	PR c++/12132
+	* g++.dg/template/error11.C: New test.
+
+	PR c++/13451
+	* g++.dg/template/class2.C: New test.
+
 2004-01-05  Nathan Sidwell  <nathan@codesourcery.com>
 	Richard Sandiford <rsandifo@redhat.com>
 
--- /Users/regress/tbox/changelog_mail/gcc/libjava/ChangeLog	Mon Jan  5 11:37:12 2004
+++ gcc/libjava/ChangeLog	Mon Jan  5 19:07:19 2004
@@ -1,3 +1,85 @@
+2004-01-05  Thomas Fitzsimmons  <fitzsim@redhat.com>
+
+	* jni/gtk-peer/gnu_java_awt_peer_gtk_GtkEvents.c
+	(pre_event_handler): Set all insets to 0 when a Configure event
+	is received for a GtkPlug.
+	* gnu/java/awt/EmbeddedWindow.java (window_id): Rename handle.
+	Make handle long, not int.
+	(EmbeddedWindow()): New constructor.
+	(EmbeddedWindow(int)): Rename window_id to handle.  Make handle
+	long, not int.
+	(setHandle): New method.
+	(getHandle): Return long, not int.
+	* gnu/java/awt/peer/EmbeddedWindowPeer.java (embed): New method
+	declaration.
+	* gnu/java/awt/peer/gtk/GtkEmbeddedWindowPeer.java,
+	jni/gtk-peer/gnu_java_awt_peer_gtk_GtkEmbeddedWindowPeer.c:
+	(create(long)): Take long parameter, not int.  Cast gtk_plug_new
+	argument to GdkNativeWindow.
+	(construct): New method.
+	(embed): New method.
+
+	* gnu/java/awt/peer/gtk/GtkScrollPanePeer.java,
+	jni/gtk-peer/gnu_java_awt_peer_gtk_GtkScrollPanePeer.c
+	(create(int, int)): New method.
+	(create): Call new create method.
+	(gtkScrolledWindowNew, gtkScrolledWindowSetSize): Remove
+	methods.
+	(childResized): Remove native implementation.  Implement in
+	Java.
+	(getHScrollbarHeight, getVScrollbarWidth): Call
+	gtk_widget_size_request to get scrollbar dimensions.
+	* java/awt/ScrollPane.java (getViewportSize): Reimplement.  Only
+	call getVScrollbarWidth and getHScrollbarHeight when vertical
+	and horizontal scrollbars respectively are needed.
+	(doLayout): Enlarge child if it is smaller than the viewport.
+
+2004-01-05  Fernando Nasser  <fnasser@redhat.com>
+
+	* java/awt/Dialog.java (constructor): Accept null title as per spec.
+	* java/awt/FileDialog.java (constructor): Throw exception on invalid
+	argument as per spec.
+
+2004-01-05  Fernando Nasser  <fnasser@redhat.com>
+
+	* java/awt/Choice.java (add): Leave posting of ItemEvents to peer.
+	(insert): Ditto.
+	(remove): Ditto.  Also, Check for valid argument.
+	(removeAll): Use peer interface method.
+	* gnu/java/awt/peer/gtk/GtkChoicePeer.java (nativeAdd): New name for
+	native add function.
+	(nativeRemove): New name for native remove function.
+	(getHistory): New native function.
+	(constructor): Generate ItemEvent.
+	(add): Ditto, if selection is changed.
+	(remove): Ditto, ditto.
+	(removeAll): Add implementation.
+	(handleEvent): Remove.  Dead code.
+	(choicePostItemEvent): Add comment.
+	* jni/gtk-peer/gnu_java_awt_peer_gtk_GtkChoicePeer.c
+	(Java_gnu_java_awt_peer_gtk_GtkChoicePeer_append): Add comments.
+	(Java_gnu_java_awt_peer_gtk_GtkChoicePeer_add): Rename to...
+	(Java_gnu_java_awt_peer_gtk_GtkChoicePeer_nativeAdd): New name.  Add
+	comments and fix condition to change selection.
+	(Java_gnu_java_awt_peer_gtk_GtkChoicePeer_remove): Rename to...
+	(Java_gnu_java_awt_peer_gtk_GtkChoicePeer_nativeRemove): New name.  Add
+	remove all capability.
+	(Java_gnu_java_awt_peer_gtk_GtkChoicePeer_getHistory): New function.
+	(item_activate): Add cast to remove compiler warning.
+
+2004-01-05  Thomas Fitzsimmons  <fitzsim@redhat.com>
+
+	* gnu/java/awt/peer/gtk/GtkComponentPeer.java,
+	jni/gtk-peer/gnu_java_awt_peer_gtk_GtkComponentPeer.c
+	(getPreferredSize): Call preferredSize.
+	(preferredSize): Call gtkWidgetGetPreferredDimensions.
+	(getMinimumSize): Call minimumSize.
+	(minimumSize): Call gtkWidgetGetPreferredDimensions.
+	(gtkWidgetGetDimensions): Return the peer widget's current size
+	request.
+	(gtkWidgetGetPreferredDimensions): Return the peer widget's
+	natural size request.
+
 2004-01-05  Sascha Brawer  <brawer@dandelis.ch>
 
 	Thanks to Brian Gough <bjg@network-theory.com>

ChangeLog entries between 2004-01-05T19:35:32Z and the last time everything
passed, on 2004-01-05T04:40:34Z:
--- /Users/regress/tbox/changelog_pass/gcc/gcc/ChangeLog	Sun Jan  4 20:41:35 2004
+++ gcc/gcc/ChangeLog	Mon Jan  5 11:36:29 2004
@@ -1,3 +1,86 @@
+2004-01-05  Daniel Berlin  <dberlin@dberlin.org>
+	
+	* ggc-zone.c: Remove everything in #ifdef USING_MALLOC_PAGE_GROUPS
+	(USING_MMAP): We don't support non-mmap.
+	(struct alloc_chunk): Steal 1 bit from typecode, use it to mark
+	large objects.
+	(struct page_entry): Remove bytes_free.
+	(struct page_table_chain): Remove.
+	(struct globals): Remove page_table member.
+	(loookup_page_table_entry): Function deleted.
+	(set_page_table_entry): Ditto.
+	(ggc_allocated_p): No longer need page table lookups.
+	(ggc_marked_p): Ditto.
+	(alloc_small_page): Don't care about bytes_free anymore.
+	(alloc_large_page): Round up size.
+	(ggc_alloc_zone_1): Mark large objects as such, and calculate
+	their size the new way. 
+	Remove page table lookups and setting.
+	(ggc_get_size): Calculate large object size the new way.
+	(sweep_pages): Redo to account for fact that we no longer have
+	bytes_free.
+	(ggc_collect): No longer need to reincrement bytes_free.
+	(ggc_pch_alloc_object): Handle new large objects properly.
+	(ggc_pch_read): Put PCH stuff into it's own uncollected zone.
+
+2004-01-05  Kazu Hirata  <kazu@cs.umass.edu>
+
+	* doc/invoke.texi: Remove a page break.
+
+2004-01-05  Kazu Hirata  <kazu@cs.umass.edu>
+
+	* config/avr/avr.c (avr_output_function_prologue): Remove an
+	extra pair of curly braces.
+
+2004-01-05  Kazu Hirata  <kazu@cs.umass.edu>
+
+	* config/mn10300/mn10300.c: Fix comment formatting.
+	* config/mn10300/mn10300.h: Likewise.
+
+2004-01-05  Richard Kenner  <kenner@vlsi1.ultra.nyu.edu>
+
+	* tree.h: Update documentation on nothrow_flag.
+	* print-tree.c (print_node): Print TREE_NOTHROW as "align-ok" for
+	types.
+
+2004-01-05  Kazu Hirata  <kazu@cs.umass.edu>
+
+	* doc/invoke.texi: Remove traces of dead ports.
+
+2004-01-05  Richard Sandiford  <rsandifo@redhat.com>
+
+	* doc/invoke.texi: Add documentation for the MIPS -mexplicit-relocs
+	option.
+
+2004-01-05  Richard Sandiford  <rsandifo@redhat.com>
+
+	PR target/12945
+	* coverage.c (coverage_counter_alloc): Set SYMBOL_FLAG_LOCAL for
+	counter labels.
+	* config/mips/mips.c (INTERNAL_SYMBOL_P): Delete.
+	(mips_classify_symbol): Always treat SYMBOL_REF_FLAG as indicating
+	string constants if TARGET_MIPS16.  Use SYMBOL_REF_DECL to check
+	the binding of decl symbols, otherwise check SYMBOL_REF_LOCAL_P.
+	(mips_symbol_insns): Don't trust the local/global classification.
+	(m16_usym8_4, m16_usym5_4): Same mips16 change as mips_classify_symbol.
+	(override_options): Make -mabicalls -fno-unit-at-a-time imply
+	-mno-explicit-relocs.
+	(mips_encode_section_info): Don't use SYMBOL_REF_FLAG to distinguish
+	between local and global symbols.
+
+2004-01-05  Richard Sandiford  <rsandifo@redhat.com>
+
+	* config/mips/mips-protos.h (mips_dangerous_for_la25_p): Declare.
+	(mips_preferred_reload_class): Declare.
+	* config/mips/mips.h (DANGEROUS_FOR_LA25_P): Replace with function.
+	(EXTRA_CONSTRAINT): Update accordingly.
+	(PREFERRED_RELOAD_CLASS): Use mips_preferred_reload_class.
+	* config/mips/mips.c (mips_dangerous_for_la25_p): New function.
+	(mips_preferred_reload_class): New function.  Prefer LEA_REGS if
+	mips_dangerous_for_la25_p.
+	(mips_secondary_reload_class): Use LEA_REGS rather than GR_REGS
+	if mips_dangerous_for_la25_p.
+
 2004-01-05  Bernardo Innocenti  <bernie@develer.com>
 
 	* config/m68k/m68k.c (output_andsi3): Fix signed/unsigned comparison
--- /Users/regress/tbox/changelog_pass/gcc/gcc/cp/ChangeLog	Sun Jan  4 20:41:38 2004
+++ gcc/gcc/cp/ChangeLog	Mon Jan  5 04:07:32 2004
@@ -1,5 +1,33 @@
 2004-01-04  Mark Mitchell  <mark@codesourcery.com>
 
+	PR c++/13157
+	* name-lookup.c (lookup_using_namespace): Remove spacesp
+	parameter.
+	(unqualified_namespace_lookup): Likewise.
+	(lookup_qualified_name): Adjust accordingly.
+	(lookup_name_real): Likewise.
+	(lookup_arg_dependent): Do not eliminate the namespace of the
+	functions found by unqualified name lookup unless that is the
+	current namespace.
+
+2004-01-04  Andrew Pinski  <pinskia@physics.uc.edu>
+
+	* semantics.c (push_deferring_access_checks): Fix format.
+	(resume_deferring_access_checks): Likewise.
+	(stop_deferring_access_checks): Likewise.
+	(pop_deferring_access_checks): Likewise.
+	(get_deferred_access_checks): Likewise.
+	(pop_to_parent_deferring_access_checks): Likewise.
+	(perform_deferred_access_checks): Likewise.
+	(perform_or_defer_access_check): Likewise.
+
+2004-01-04  Richard Henderson  <rth@redhat.com>
+
+	* call.c (build_over_call): Don't create a save_expr of an
+	aggregate, but rather its address.
+
+2004-01-04  Mark Mitchell  <mark@codesourcery.com>
+
 	PR c++/13529
 	* parser.c (cp_parser_postfix_expression): Allow "." to appear in
 	an offsetof expression.
--- /Users/regress/tbox/changelog_pass/gcc/gcc/testsuite/ChangeLog	Sun Jan  4 20:41:43 2004
+++ gcc/gcc/testsuite/ChangeLog	Mon Jan  5 04:07:36 2004
@@ -1,4 +1,13 @@
+2004-01-05  Nathan Sidwell  <nathan@codesourcery.com>
+	Richard Sandiford <rsandifo@redhat.com>
+
+	PR c++/13387
+	* g++.dg/opt/alias3.C: New test.
+
 2004-01-04  Mark Mitchell  <mark@codesourcery.com>
+
+	PR c++/13157
+	* g++.dg/template/koenig3.C: New test.
 
 	PR c++/13529
 	* g++.dg/parse/offsetof3.C: New test.
--- /Users/regress/tbox/changelog_pass/gcc/libjava/ChangeLog	Sun Jan  4 05:48:58 2004
+++ gcc/libjava/ChangeLog	Mon Jan  5 11:37:12 2004
@@ -1,3 +1,9 @@
+2004-01-05  Sascha Brawer  <brawer@dandelis.ch>
+
+	Thanks to Brian Gough <bjg@network-theory.com>
+	* java/awt/geom/CubicCurve2D.java (solveCubic): Implemented.
+	* java/awt/geom/QuadCurve2D.java (solveQuadratic): Re-written.
+
 2004-01-04  Matthias Klose  <doko@debian.org>
 
 	* aclocal.m4: Rebuilt using "aclocal -I .".
-------------- next part --------------
-- 
Geoffrey Keating <geoffk@apple.com> 
(via an automated GCC regression-testing script.)


More information about the Gcc-regression mailing list