Regression for trunk on athlon_mp-pc-linux-gnu
Autocrasher
autocrasher@devphil.com
Sun Nov 2 10:34:00 GMT 2003
One or more new FAIL's have appeared for athlon_mp-pc-linux-gnu:
g++.sum g++.old-deja/g++.mike/eh34.C
These tests passed the last time they were ran.
Attached are the ChangeLogs since the previous run. Possibly a patch with
your name on it has caused the problem(s).
The full transcript is at http://www.devphil.com/build/
This particular run used standard (previously installed) binutils.
This email is generated by a machine, not sent from a person. If you think
it's been sent to you in error, please see the gcc-regression list archives
for possible followup discussion; this could be legitimate or it could be a
false positive. Also watch for email from the other regression testers and
check the logs from the known autobuilders.
With love,
The Autocrasher (Phil's Builder Bot, version 2.0)
=========================================================================
diff -u1r previous/CL/gcc/ChangeLog current/CL/gcc/ChangeLog
--- previous/CL/gcc/ChangeLog 2003-11-01 04:30:03.000000000 -0500
+++ current/CL/gcc/ChangeLog 2003-11-02 04:30:04.000000000 -0500
@@ -1 +1,69 @@
+2003-11-02 Eric Botcazou <ebotcazou@libertysurf.fr>
+
+ * config/sparc/sparc.c (function_arg_partial_nregs) [TARGET_ARCH64]:
+ Return 0 for all complex modes whose size is lesser or equal to
+ a word. Add a ??? comment for the condition used with 16-byte
+ aligned modes.
+
+2003-11-01 Kelley Cook <kcook@gcc.gnu.org>
+
+ * .cvsignore: Remove c-parse* and tradcif.c.
+ * objc/.cvsignore: Delete.
+
+2003-11-01 Roger Sayle <roger@eyesopen.com>
+
+ * unwind-sjlj.c (_Unwind_GetCFA): Return (_Unwind_Word)0 instead
+ of NULL.
+
+2003-11-01 John David Anglin <dave.anglin@nrc-cnrc.gc.ca>
+
+ * som.h (DO_GLOBAL_DTORS_BODY): Change to C90 declaration.
+
+ * libgcc2.c (SYMBOL__MAIN): Provide C90 declaration.
+
+ * collect2.c (scan_libraries): Fix typos.
+
+ PR preprocessor/12847
+ * cppfiles.c, cppexp.c, cpperror.c, cpplib.h, cpplib.c, cpplex.c,
+ cppinit.c, cpptrad.c, cppmacro.c, fix-header.c, cpppch.c, c-pch.c,
+ c-incpath.c, cppcharset.c (DL_WARNING, DL_WARNING_SYSHDR, DL_PEDWARN,
+ DL_ERROR, DL_ICE, DL_EXTRACT, DL_WARNING_P): Prefix macro names with
+ "CPP_".
+
+2003-11-01 Fariborz Jahanian <fjahanian@apple.com>
+
+ * config/rs6000/rs6000.c (rs6000_mixed_function_arg): Correct
+ no_units calculation.
+
+2003-11-01 Andreas Jaeger <aj@suse.de>
+
+ * unwind-dw2.c (_Unwind_FrameState): Remove commas at end of
+ enumeration list.
+
+2003-11-01 Andreas Schwab <schwab@suse.de>
+
+ * config/ia64/sysv4.h (SDATA_SECTION_FUNCTION): Update to C90
+ prototypes.
+ (SBSS_SECTION_FUNCTION): Likewise.
+
+2003-11-01 Kaveh R. Ghazi <ghazi@caip.rutgers.edu>
+
+ * Makefile.in (GCC_CFLAGS): Add @WERROR@ for target files.
+
+2003-11-01 Andreas Tobler <a.tobler@schweiz.ch>
+
+ * config/rs6000/sysv4.h (EXTRA_SECTION_FUNCTIONS): Update to C90
+ prototypes.
+
+2003-11-01 Andreas Jaeger <aj@suse.de>
+
+ * unwind-dw2.c (_Unwind_FindEnclosingFunction): Constify variable.
+ (uw_frame_state_for): Constify variables.
+ (extract_cie_info): Constify first argument.
+
+ * unwind-dw2-fde-darwin.c: Adjust prototype of
+ _Unwind_Find_registered_FDE for recent changes.
+ (examine_objects): Constify return value and local variable result.
+ (_Unwind_Find_FDE): Constify return value and local variable ret.
+
2003-10-31 Per Bothner <pbothner@apple.com>
@@ -51,4 +119,4 @@
-2003-10-31 Andreas Jaeger <aj@suse.de>,
- Zack Weinberg <zack@codesourcery.com>
+2003-10-31 Andreas Jaeger <aj@suse.de>,
+ Zack Weinberg <zack@codesourcery.com>
@@ -58,3 +126,3 @@
Constify void * argument.
- * unwind-dw2-fde.h (struct fde_vector):
+ * unwind-dw2-fde.h (struct fde_vector):
Constify 'orig_data' and 'array' fields.
@@ -79,3 +147,3 @@
Use const pointer types in sizeof expressions, for clarity.
- * unwind-dw2-fde-glibc.c
+ * unwind-dw2-fde-glibc.c
(_Unwind_find_registered_FDE, _Unwind_find_FDE): Constify return value.
@@ -128,3 +196,3 @@
- * ggc-page.c (ggc_pch_read): Wrap call to poison_pages in
+ * ggc-page.c (ggc_pch_read): Wrap call to poison_pages in
ENABLE_GC_CHECKING not in GGC_POISON.
diff -u1r previous/CL/gcc/cp/ChangeLog current/CL/gcc/cp/ChangeLog
--- previous/CL/gcc/cp/ChangeLog 2003-10-27 04:30:06.000000000 -0500
+++ current/CL/gcc/cp/ChangeLog 2003-11-02 04:30:16.000000000 -0500
@@ -1 +1,7 @@
+2003-11-01 Kriang Lerdsuwanakij <lerdsuwa@users.sourceforge.net>
+
+ PR c++/12796
+ * class.c (handle_using_decl): Set input_location before calling
+ error_not_base_type.
+
2003-10-26 Kriang Lerdsuwanakij <lerdsuwa@users.sourceforge.net>
diff -u1r previous/CL/gcc/testsuite/ChangeLog current/CL/gcc/testsuite/ChangeLog
--- previous/CL/gcc/testsuite/ChangeLog 2003-11-01 04:30:19.000000000 -0500
+++ current/CL/gcc/testsuite/ChangeLog 2003-11-02 04:30:19.000000000 -0500
@@ -1 +1,11 @@
+2003-11-02 Eric Botcazou <ebotcazou@libertysurf.fr>
+
+ * gcc.dg/complex-1.c: New test.
+
+2003-11-01 Kriang Lerdsuwanakij <lerdsuwa@users.sourceforge.net>
+
+ PR c++/12796
+ * g++.dg/template/crash13.C: Adjust expected error location.
+ * g++.old-deja/g++.brendan/ns1.C: Likewise.
+
2003-10-31 Richard Earnshaw <rearnsha@arm.com>
More information about the Gcc-regression
mailing list