[PATCH v3 1/8] tree-object-size: Replace magic numbers with enums

Jakub Jelinek jakub@redhat.com
Fri Nov 26 18:01:06 GMT 2021


On Fri, Nov 26, 2021 at 11:23:31PM +0530, Siddhesh Poyarekar wrote:
> On 11/26/21 22:16, Jakub Jelinek wrote:
> > On Fri, Nov 26, 2021 at 10:58:44AM +0530, Siddhesh Poyarekar wrote:
> > > A simple cleanup to allow inserting dynamic size code more easily.
> > > 
> > > gcc/ChangeLog:
> > > 
> > > 	* tree-object-size.c: New enum.
> > > 	(object_sizes, computed, addr_object_size,
> > > 	compute_builtin_object_size, expr_object_size, call_object_size,
> > > 	merge_object_sizes, plus_stmt_object_size,
> > > 	collect_object_sizes_for, init_object_sizes, fini_object_sizes,
> > > 	object_sizes_execute): Replace magic numbers with enums.
> > > 
> > > Signed-off-by: Siddhesh Poyarekar <siddhesh@gotplt.org>
> > 
> > Ok, thanks.
> 
> Thanks, may I push these patches since they're independent cleanups?

The first two, yes.

	Jakub



More information about the Gcc-patches mailing list