[PATCH v3 1/8] tree-object-size: Replace magic numbers with enums

Jakub Jelinek jakub@redhat.com
Fri Nov 26 16:46:29 GMT 2021


On Fri, Nov 26, 2021 at 10:58:44AM +0530, Siddhesh Poyarekar wrote:
> A simple cleanup to allow inserting dynamic size code more easily.
> 
> gcc/ChangeLog:
> 
> 	* tree-object-size.c: New enum.
> 	(object_sizes, computed, addr_object_size,
> 	compute_builtin_object_size, expr_object_size, call_object_size,
> 	merge_object_sizes, plus_stmt_object_size,
> 	collect_object_sizes_for, init_object_sizes, fini_object_sizes,
> 	object_sizes_execute): Replace magic numbers with enums.
> 
> Signed-off-by: Siddhesh Poyarekar <siddhesh@gotplt.org>

Ok, thanks.

	Jakub



More information about the Gcc-patches mailing list