[PATCH 01/10] tree-object-size: Replace magic numbers with enums

Jakub Jelinek jakub@redhat.com
Fri Nov 19 16:00:17 GMT 2021


On Wed, Nov 10, 2021 at 12:31:27AM +0530, Siddhesh Poyarekar wrote:
> A simple cleanup to allow inserting dynamic size code more easily.
> 
> gcc/ChangeLog:
> 
> 	* tree-object-size.c: New enum.
> 	(object_sizes, computed, addr_object_size,
> 	compute_builtin_object_size, init_object_sizes,
> 	fini_object_sizes, object_sizes_execute): Replace magic numbers
> 	with enums.

Ok.

	Jakub



More information about the Gcc-patches mailing list