[PATCH] rs6000: Better error messages for power8/9-vector builtins

David Edelsohn dje.gcc@gmail.com
Wed Nov 17 20:04:26 GMT 2021


On Wed, Nov 17, 2021 at 3:02 PM Segher Boessenkool
<segher@kernel.crashing.org> wrote:
>
> > It's not a strong objection, since specifying "-mno-vsx" should be
> > uncommon.  (Right?)  And, specifying "-mcpu=power8 -mvsx" is harmless.
>
> Maybe the warning could say "requires -mcpu=power8 (and -mvsx)"?  Is
> that clearer, to your eye?

Maybe "requires -mcpu=power8 with VSX" or "requires -mcpu=power8 with
VSX enabled"?

Thanks, David


More information about the Gcc-patches mailing list