[PATCH] x86: Document -fcf-protection requires i686 or newer

H.J. Lu hjl.tools@gmail.com
Mon Nov 1 11:21:34 GMT 2021


On Fri, Oct 29, 2021 at 3:04 PM Eric Gallager <egall@gwmail.gwu.edu> wrote:
>
> On Thu, Oct 21, 2021 at 12:49 PM H.J. Lu via Gcc-patches
> <gcc-patches@gcc.gnu.org> wrote:
> >
> >         PR target/98667
> >         * doc/invoke.texi: Document -fcf-protection requires i686 or
> >         new.
> > ---
> >  gcc/doc/invoke.texi | 3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
> > index c66a25fcd69..71992b8c597 100644
> > --- a/gcc/doc/invoke.texi
> > +++ b/gcc/doc/invoke.texi
> > @@ -15542,7 +15542,8 @@ which functions and calls should be skipped from instrumentation
> >  (@pxref{Function Attributes}).
> >
> >  Currently the x86 GNU/Linux target provides an implementation based
> > -on Intel Control-flow Enforcement Technology (CET).
> > +on Intel Control-flow Enforcement Technology (CET) which works for
> > +i686 processor or newer.
>
> I think "processor" should be pluralized to "processors"? Also,
> possibly a missing comma after "(CET)"?
>

Can you submit a patch?

Thanks.

-- 
H.J.


More information about the Gcc-patches mailing list