rs6000: Require ELFv2 ABI for ROP test (PR100750)

Bill Schmidt wschmidt@linux.ibm.com
Tue Jun 1 16:18:05 GMT 2021


Hi!  PR100750 reports a failure on my part to require the ELFv2 ABI for
one of the ROP tests.  This fixes that.

Tested on powerpc64-linux-gnu, committed as obvious.

Thanks!
Bill


PR100750: Require ELFv2 ABI for ROP test

2021-06-01  Bill Schmidt  <wschmidt@linux.ibm.com>

gcc/testsuite/
	PR testsuite/100750
	* gcc.target/powerpc/rop-5.c: Require ELFv2 ABI.

diff --git a/gcc/testsuite/gcc.target/powerpc/rop-5.c b/gcc/testsuite/gcc.target/powerpc/rop-5.c
index cf04ea90eeb..f2594df8a44 100644
--- a/gcc/testsuite/gcc.target/powerpc/rop-5.c
+++ b/gcc/testsuite/gcc.target/powerpc/rop-5.c
@@ -1,4 +1,5 @@
  /* { dg-do compile } */
+/* { dg-require-effective-target powerpc_elfv2 } */
  /* { dg-options "-O2 -mdejagnu-cpu=power10 -mrop-protect" } */
  
  /* Verify that __ROP_PROTECT__ is predefined for -mrop-protect.  */



More information about the Gcc-patches mailing list