[PATCH] Fix PR 90142: contrib/download_prerequisites uses test ==

Richard Biener richard.guenther@gmail.com
Tue Aug 31 06:08:11 GMT 2021


On Mon, Aug 30, 2021 at 10:49 PM apinski--- via Gcc-patches
<gcc-patches@gcc.gnu.org> wrote:
>
> From: Andrew Pinski <apinski@marvell.com>
>
> Since == is not portable, it is better to use = in contrib/
> download_prerequisites.  The only place == was used is inside
> the function md5_check which is used only on Mac OS X.
>
> Tested on Mac OS X as:
> ./contrib/download_prerequisites --md5
> Both with all files having the correct checksum and one with a broken one.

Ok.

> contrib/ChangeLog:
>
>         * download_prerequisites (md5_check): Replace == inside
>         test with = to be more portable.
> ---
>  contrib/download_prerequisites | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/contrib/download_prerequisites b/contrib/download_prerequisites
> index 8f69b61f5a9..11c283ecb1a 100755
> --- a/contrib/download_prerequisites
> +++ b/contrib/download_prerequisites
> @@ -113,7 +113,7 @@ md5_check() {
>    md5_checksum_output=$(md5 -r "${file_to_check}")
>    # Grab the text before the first space
>    md5_checksum_detected="${md5_checksum_output%% *}"
> -  [ "${md5_checksum_expected}" == "${md5_checksum_detected}" ] \
> +  [ "${md5_checksum_expected}" = "${md5_checksum_detected}" ] \
>      || die "Cannot verify integrity of possibly corrupted file ${file_to_check}"
>    echo "${file_to_check}: OK"
>  }
> --
> 2.17.1
>


More information about the Gcc-patches mailing list