[PATCH] rs6000: Fix misnamed built-in

Segher Boessenkool segher@kernel.crashing.org
Wed Sep 16 10:32:00 GMT 2020

On Tue, Sep 15, 2020 at 08:38:42PM -0500, Bill Schmidt wrote:
> The description	in rs6000-builtin.def provides for a builtin named
> __builtin_altivec_xst_len_r.  However, it is hand-defined in
> altivec_init_builtins as __builtin_xst_len_r, against the usual naming
> practice.  Fix that.
> Bootstrapped and tested on powerpc64le-unknown-linux-gnu with no
> regressions; committed as obvious.

Does no one use this?  Should we provide an alias with the old (wrong)
name?  What does the documentation say it should be?

It is obvious of course, except for that "might break users' code"
thing ;-)


More information about the Gcc-patches mailing list