c++: Rename DECL_BUILTIN_P to DECL_UNDECLARED_BUILTIN_P

Nathan Sidwell nathan@acm.org
Wed Oct 7 12:06:39 GMT 2020


I realized I'd misnamed	DECL_BUILTIN_P,	it's only true of compiler
builtins unless and until the user declares them -- at that point
they're real decls, and	will have a location in	the user's source.
(BUILT_IN_FN and friends still work though).  This renames them	so
future-me is not confused as to why the predicate becomes false.


	gcc/cp/
         * cp-tree.h (DECL_BUILTIN_P): Rename to	...
         (DECL_UNDECLARED_BUILTIN_P): ... here.
         * decl.c (duplicate_decls): Adjust.
         * name-lookup.c	(anticipated_builtin_p): Adjust.
         (do_nonmember_using_decl): Likewise.
         libcc1/
         * libcp1plugin.cc (supplement_binding):	Rename
	DECL_BUILTIN_P.


pushing to trunk

nathan
-- 
Nathan Sidwell
-------------- next part --------------
A non-text attachment was scrubbed...
Name: decl-builtin-rename.diff
Type: text/x-patch
Size: 2638 bytes
Desc: not available
URL: <https://gcc.gnu.org/pipermail/gcc-patches/attachments/20201007/6fd96fd6/attachment.bin>


More information about the Gcc-patches mailing list