[PATCH] libstdc++: Fix error shown during Solaris build

Rainer Orth ro@CeBiTec.Uni-Bielefeld.DE
Mon Nov 16 11:47:50 GMT 2020


Hi Jonathan,

>>I did try to use "-l ?[[:alnum:]]+" but Solaris sed only supports BREs
>>(as POSIX requires) and there doesn't seem to be an equivalent of the
>>GNU sed -E option to use EREs.
>
> POSIX agreed to add the -E option 8 years ago but that hasn't made it
> into the standard yet (because we're still on POSIX 2011+TC1+TC2 and
> presumably have to wait for the next revision).

and even so we still do support Solaris 11.3 from 2015 which certainly
won't get such a change.

	Rainer

-- 
-----------------------------------------------------------------------------
Rainer Orth, Center for Biotechnology, Bielefeld University


More information about the Gcc-patches mailing list