[PATCH] Use dump_asm_name for Callers/Calls in dump.

Martin Liška mliska@suse.cz
Tue Jan 7 10:27:00 GMT 2020


On 1/7/20 11:12 AM, Martin Jambor wrote:
> I try to use just the symtab_order numbers whenever I can to avoid
> confusion

Which is fine. Apparently there are just few usages of manual printing
of a symtab node and order like:

       fprintf (f,
	       "%*s%s/%i %s\n%*s  freq:%4.2f",
	       indent, "", callee->name (), callee->order,

I can replace these with symtab_node::dump_{asm_}name.

> but - at least if we care about the non-asm name at all -
> shouldn't the dump have both the name and asm_name?

That will probably make output of functions like cgraph_node::dump
harder to read.

> If not, then I
> guess get_dump_name should print asm name too to get consistency
> everywhere in the IPA dumps not just the graph dump bit.

One alternative would be to print always asm names? Or we can drive that
with a flag? Similar thing do all tools like objdump, as, .. They
have --demangle (--no-demangle) options.

Martin

> 
> Martin



More information about the Gcc-patches mailing list