[PATCH] [AVX512]For vector compare to mask register, UNSPEC is needed instead of comparison operator [PR96243]

Jakub Jelinek jakub@redhat.com
Mon Aug 31 07:53:23 GMT 2020


On Tue, Aug 11, 2020 at 05:43:48PM +0800, Hongtao Liu via Gcc-patches wrote:
> Hi:
>   The issue is described in the bugzilla.
>   Bootstrap is ok, regression test for i386/x86-64 backend is ok.
>  Ok for trunk?
> 
> ChangeLog
> gcc/
>         PR target/96551
>         * config/i386/sse.md (vec_unpacku_float_hi_v16si): For vector
>         compare to integer mask, don't use gen_rtx_LT , use

Please remove the space before comma.

>         ix86_expand_mask_vec_cmp instead.
>         (vec_unpacku_float_hi_v16si): Ditto.
> 
> gcc/testsuite
>         * gcc.target/i386/pr96551-1.c: New test.
>         * gcc.target/i386/pr96551-2.c: New test.

And please rename the testcases to avx512f-pr96551-{1,2}.c.

> +  for (int i = 0; i != 256; i++)
> +    if (exp[i] != b[i])
> +      __builtin_abort ();

You can use just abort (); here, given that avx512-check.h includes
stdlib.h.

Ok for trunk with those nits changed.

	Jakub



More information about the Gcc-patches mailing list