[PATCH] rs6000: Rename instruction xvcvbf16sp to xvcvbf16spn

Segher Boessenkool segher@kernel.crashing.org
Tue Aug 18 18:34:50 GMT 2020


On Tue, Aug 18, 2020 at 01:30:53PM -0500, Peter Bergner wrote:
> The xvcvbf16sp mnemonic, which was just added in ISA 3.1 has been renamed
> to xvcvbf16spn, to make it consistent with the other non-signaling conversion
> instructions which all end with "n".  The only use of this instruction is in
> an MMA conversion built-in function, so there is little to no compatibility
> issue.
> 
> I just pushed the patch that does the rename to binutils today.
> 
> Ok for trunk and the GCC 10 branch after testing is clean?

Yes, okay everywhere.  Thanks!


Segher


> gcc/
> 	* config/rs6000/rs6000-builtin.def (BU_VSX_1): Rename xvcvbf16sp to
> 	xvcvbf16spn.
> 	* config/rs6000/rs6000-call.c (builtin_function_type): Likewise.
> 	* config/rs6000/vsx.md: Likewise.
> 	* doc/extend.texi: Likewise.
> 
> gcc/testsuite/
> 	* gcc.target/powerpc/mma-builtin-3.c: Rename xvcvbf16sp to xvcvbf16spn.


More information about the Gcc-patches mailing list