[PATCH] musl: use correct long double abi by default
Segher Boessenkool
segher@kernel.crashing.org
Fri Nov 15 18:19:00 GMT 2019
On Fri, Nov 15, 2019 at 06:03:25PM +0000, Szabolcs Nagy wrote:
> On 15/11/2019 17:48, Segher Boessenkool wrote:
> > I think it would be much more readable and maintainable if you did
> > something like
> >
> > case "$target" in
> > powerpc*-*-linux-musl)
> > gcc_cv_target_ldbl128=no
> > ;;
> > s390*-*-linux-musl)
> > gcc_cv_target_ldbl128=yes
> > ;;
> > powerpc*-*-linux* |
> > sparc*-*-linux* |
> > s390*-*-linux* |
> > alpha*-*-linux*)
> > AC_ARG_WITH(long-double-128,
> >
> > etc., i.e. add the musl targets to the main switch here?
>
> i'm fine with that, it means the --with-long-double-128
> switch does not work on *-musl,
I thought that is what you wanted to do. If you just want to change the
default, do that *before* this block, not *in* it?
Segher
More information about the Gcc-patches
mailing list