make value_range the base class and value_range_equiv the derived class

Aldy Hernandez aldyh@redhat.com
Tue Nov 5 13:22:00 GMT 2019


The base class for ranges is currently value_range_base, which is rather 
long and cumbersome.  It also occurs more often than the derived class 
of value_range.  To avoid confusion, and save typing, this patch does a 
global rename from value_range to value_range_equiv, and from 
value_range_base to value_range.

This way, the base class is simply value_range, and the derived class is 
value_range_equiv which explicitly states what it does.

OK?

Aldy

p.s. There are a few minor cleanups throughout... like moving some 
random variable definitions closer to their first use.  I figured they 
were harmless while I was in the vicinity.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: curr.patch
Type: text/x-patch
Size: 201177 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/gcc-patches/attachments/20191105/9894b1ae/attachment.bin>


More information about the Gcc-patches mailing list