[PATCH] Updated patches for the port of gccgo to GNU/Hurd

Ian Lance Taylor iant@golang.org
Mon Feb 11 06:09:00 GMT 2019


On Sun, Feb 10, 2019 at 3:41 AM Svante Signell <svante.signell@gmail.com> wrote:
>
> On Sat, 2019-02-09 at 23:57 +0100, Svante Signell wrote:
> > On Sat, 2019-02-09 at 14:40 -0800, Ian Lance Taylor wrote:
> > > On Fri, Feb 8, 2019 at 3:07 PM Matthias Klose <doko@debian.org> wrote:
> > > > On 07.02.19 06:04, Ian Lance Taylor wrote:
> > > What are the lines before that in the log?  For some reason libtool is
> > > being invoke with no source files.  The lines before the failing line
> > > should show an invocation of match.sh that determines the source
> > > files.
> >
> > Thanks for your job upstreaming the patches!
> >
> > I've found some problems. Current problem is with the mksysinfo.sh patch. But
> > there are some other things missing. New patches will be submitted tomorrow.
>
> Attached are three additional patches needed to build libgo on GNU/Hurd:
> src_libgo_mksysinfo.sh.diff
> src_libgo_go_syscall_wait.c.diff
> src_libgo_testsuite_gotest.diff
>
> For the first patch, src_libgo_mksysinfo.sh.diff, I had to go back to the old
> version, using sed -i -e. As written now ${fsid_to_dev} expands to
> fsid_to_dev='-e '\''s/st_fsid/Dev/'\''' resulting in: "sed: -e expression #4,
> char 1: unknown command: `''". Unfortunately, I have not yet been able to modify
> the expansion omitting the single qoutes around the shell variable.

I'm sorry, I don't want to use "sed -i".  That loses the original file
and makes it harder to reconstruct what has happened.

> The second patch, src_libgo_go_syscall_wait.c.diff, is needed since WCONTINUED
> is not defined and is needed for WIFCONTINUED to be defined in wait.h.

I don't understand that.  <sys/wait.h> is a system header file.  Are
you saying that it is impossible to use <sys/wait.h> and WIFCONTINUED
unless your source code does a #define WCONTINUED before #include'ing
<sys/wait.h>?  That seems like a bug in the Hurd library code.

> The third patch, src_libgo_testsuite_gotest.diff, is not strictly needed, but
> running the tests the annoying text is displayed: "ps: comm: Unknown format
> spec"

I get that "comm" doesn't work, but the change in that patch is simply
incorrect.  If you don't pass "comm", the "grep sleep" will never
succeed.  If there is no way to support this code on Hurd then we
should skip it, not put in a command that can never work.

Ian



More information about the Gcc-patches mailing list