[C++ Patch] Improve delete_sanity locations
Jason Merrill
jason@redhat.com
Mon Aug 5 19:06:00 GMT 2019
On 8/2/19 8:27 AM, David Malcolm wrote:
> On Fri, 2019-08-02 at 14:02 +0200, Paolo Carlini wrote:
>> Hi,
>>
>> On 31/07/19 21:39, David Malcolm wrote:
>>
>> [snip]
>>> I don't care for "cp_expr_loc_or_loc".
>>>
>>> By "_or_here" do you mean "or input_location"?
>>>
>>> Calling it "cp_expr_loc_or_input_location" would spell out what it
>>> does, but would be rather long.
>>
>> Thanks for your feedback. At this point I don't feel very strongly
>> about
>> the issue, and, well, hopefully it's just temporary material, but I
>> tested the below which proposes the name cp_expr_loc_or_input_loc.
>> Seems
>> a good balance to me. What do you think?
>
> I like it, FWIW.
OK.
Jason
More information about the Gcc-patches
mailing list