[patch] [match.pd]: missing optimization on comparison

Bernhard Reutner-Fischer rep.dot.nop@gmail.com
Sun Sep 2 10:14:00 GMT 2018


On 30 August 2018 22:20:06 CEST, Marc Glisse <marc.glisse@inria.fr> wrote:
>Hello,

>
>INTEGRALS_SIGN_PREC_MATCH: the name doesn't really match the semantics.

+#define INTEGRALS_SIGN_PREC_MATCH(A, B) \
+  TYPE_PRECISION (TREE_TYPE (A)) == TYPE_PRECISION (TREE_TYPE (B)) \
+  (TYPE_PRECISION (TREE_TYPE (A)) > TYPE_PRECISION (TREE_TYPE (B)) \
+   && !TYPE_UNSIGNED (TREE_TYPE (B)))
+

Unless my mailer somehow mangled it, isn't there some operator ( maybe || ?) missing between the eq clause and the second one?

How comes that it even compiles, presumably without a warning?

thanks,



More information about the Gcc-patches mailing list