[PING][PATCH] Make function clone name numbering independent.
Jeff Law
law@redhat.com
Mon Aug 20 19:47:00 GMT 2018
On 08/13/2018 05:58 PM, Michael Ploujnikov wrote:
> Ping and I've updated the patch since last time as follows:
>
> - unittest scans assembly rather than the constprop dump because its
> forward changed
> - unittests should handle different hosts where any of
> NO_DOT_IN_LABEL, NO_DOLLAR_IN_LABEL or __USER_LABEL_PREFIX__ may
> be defined
> - not 100% it's safe to change DECL_NAME to DECL_ASSEMBLER_NAME in
> cgraph_node::create_virtual_clone, but I've attempted to reduce
> some code duplication
> - lto-partition.c: privatize_symbol_name_1 *does* need numbered
> names
> - but cold sections don't
> - Expecting an IDENTIFIER_NODE in clone_function_name_1 avoids
> unreliable string pointer use as pointed out in the first review
> - renamed clone_function_name_1 and clone_function_name to
> numbered_clone_function_name_1 and numbered_clone_function_name to
> clarify purpose and discourage future unintended uses
Richi has more state here than I do, so I'm going to let him own it. I
know he's just returning from PTO, so it's going to take him a bit of
time to catch up.
jeff
More information about the Gcc-patches
mailing list