[PATCH 09/16] Split class rtx_reader into base_rtx_reader vs rtx_reader

Bernd Schmidt bschmidt@redhat.com
Tue Oct 11 15:53:00 GMT 2016


On 10/05/2016 06:15 PM, David Malcolm wrote:
> -	  rtx_reader_ptr->get_top_level_filename ());
> +	  base_rtx_reader_ptr->get_top_level_filename ());

I wonder if the number of changes could be minimized by retaining the 
name rtx_reader for the base class, and using something more specific 
for the derived ones. Or would that require renaming a bunch of other 
locations?

> -static void
> -read_rtx_operand (rtx return_rtx, int idx)
> +rtx
> +rtx_reader::read_rtx_operand (rtx return_rtx, int idx)
>  {
>    RTX_CODE code = GET_CODE (return_rtx);
>    const char *format_ptr = GET_RTX_FORMAT (code);

 > +
 > +  return return_rtx;
 >  }
 >

This appears to be an unrelated change. The return value needs to be 
documented.


Bernd



More information about the Gcc-patches mailing list