[PATCH] Add ggc-tests.c

Ulrich Weigand uweigand@de.ibm.com
Mon Jun 13 12:31:00 GMT 2016


Gerald Pfeifer wrote:

> The source code of need_finalization_p in ggc.h reads
> 
>    template<typename T>
>    static inline bool
>    need_finalization_p ()
>    {
>    #if GCC_VERSION >= 4003
>      return !__has_trivial_destructor (T);
>    #else
>      return true;
>    #endif
>    }
> 
> which means your self test is broken by design for any compiler
> that is not GCC in at least version 4.3, isn't it?

Just to confirm that I'm seeing the same failure on my SPU
daily build machine, which is running RHEL 5 with a host
compiler of GCC 4.1.2.

Bye,
Ulrich

-- 
  Dr. Ulrich Weigand
  GNU/Linux compilers and toolchain
  Ulrich.Weigand@de.ibm.com



More information about the Gcc-patches mailing list