[PATCH] [graphite] document that isl-0.16 is supported

Mike Stump mikestump@comcast.net
Mon Feb 1 18:30:00 GMT 2016


On Jan 29, 2016, at 8:10 AM, Sebastian Pop <s.pop@samsung.com> wrote:
> diff --git a/gcc/doc/install.texi b/gcc/doc/install.texi
> index 062f42c..3df7974 100644
> --- a/gcc/doc/install.texi
> +++ b/gcc/doc/install.texi
> @@ -383,7 +383,7 @@ installed but it is not in your default library search path, the
> @option{--with-mpc} configure option should be used.  See also
> @option{--with-mpc-lib} and @option{--with-mpc-include}.
> 
> -@item isl Library version 0.15 or 0.14.
> +@item isl Library version 0.16, 0.15, or 0.14.

So, they should commit to compatibility with apis vended, and if they do, I think we should say 0.14 or later.  This doesn’t mean that we won’t need fixes from time to time or that they will always do this, but generally that is true.  If we (they) deviate from this, _then_ we document the exceptions.  If release after release goes out, with all newer versions not working, then the list of known good versions is best; but, I’d say that something is terribly broken if we had to do that.


More information about the Gcc-patches mailing list