[PATCH, 3/6] Add recursion to make_param_constraints
Richard Biener
rguenther@suse.de
Mon Nov 2 15:25:00 GMT 2015
On Sun, 1 Nov 2015, Tom de Vries wrote:
> On 01/11/15 19:03, Tom de Vries wrote:
> >
> > So, the new patch series is:
> >
> > 1 Rename make_restrict_var_constraints to make_param_constraints
> > 2 Handle recursive restrict in function parameter
> >
> > I'll repost in reply to this message.
>
> This no-functional-changes patch:
> - moves the one constraint handling loop left in
> intra_create_variable_infos to make_restrict_var_constraints
> - renames make_restrict_var_constraints to make_param_constraints
> - adds a parameter toplevel to make_param_constraints to distinguish
> between the two calling contexts
> - adds a parmeter restrict_name that allows to pass in the name of
> restrict vars
>
> This patch was posted before at
> https://gcc.gnu.org/ml/gcc-patches/2015-10/msg03111.html .
+ if (toplevel)
+ make_constraint_from (vi, nonlocal_id);
+ else
+ make_copy_constraint (vi, nonlocal_id);
I think make_constraint_from is what we want in both cases.
Ok with this change (thus drop the toplevel parameter).
Richard.
More information about the Gcc-patches
mailing list