Change __cpp_concepts to __cpp_experimental_concepts

Jason Merrill jason@redhat.com
Fri Aug 7 09:16:00 GMT 2015


Thanks, but the name of the macro was changed in more recent drafts.

-------- Original Message --------
 From: Ed Smith-Rowland <3dw4rd@verizon.net>
 Sent: Fri, Aug 7, 2015 03:32 AM
 To: gcc-patches <gcc-patches@gcc.gnu.org>; Jason Merrill <jason@redhat.com>
 CC: 
 Subject: Change __cpp_concepts to __cpp_experimental_concepts

Jason,

My reading of

1.5 Feature-testing recommendations (Informative)
/2 ... The recommended macro name is __cpp_experimental_ followed by the 
string in the “Macro
name suffix” column in Table 1. ...

Says change __cpp_concepts to __cpp_experimental_concepts

Cool beans on getting this in.

Ed

-------------------------------------------------------------------
2015-06-30  Edward Smith-Rowland  <3dw4rd@verizon.net>

     * c-family/c-cppbuiltin.c (c_cpp_builtins): Rename __cpp_concepts
     to __cpp_experimental_concepts.
-------------------------------------------------------------------


-------------------------------------------------------------------
Index: gcc/gcc/c-family/c-cppbuiltin.c
===================================================================
--- gcc/gcc/c-family/c-cppbuiltin.c    (revision 226714)
+++ gcc/gcc/c-family/c-cppbuiltin.c    (working copy)
@@ -868,7 +868,7 @@
        if (flag_concepts)
      /* Use a value smaller than the 201507 specified in
         the TS, since we don't yet support extended auto.  */
-    cpp_define (pfile, "__cpp_concepts=201500");
+    cpp_define (pfile, "__cpp_experimental_concepts=201500");
        if (flag_sized_deallocation)
      cpp_define (pfile, "__cpp_sized_deallocation=201309");
      }
-------------------------------------------------------------------



More information about the Gcc-patches mailing list