[PATCH v3] PR libitm/61164: use always_inline consistently

Jakub Jelinek jakub@redhat.com
Mon Sep 29 13:38:00 GMT 2014


On Mon, Sep 29, 2014 at 04:53:26PM +0400, Gleb Fotengauer-Malinovskiy wrote:
> 2014-09-27 Gleb Fotengauer-Malinovskiy <glebfm@altlinux.org>

Two spaces around name on each side.
> 
> libitm/
> 
> 	PR libitm/61164
> 	* local_atomic: Rename __always_inline to __libitm_always_inline
> 	to eliminate glibc macro redefinition.

That would be
	* local_atomic (__always_inline): Rename to...
	(__libitm_always_inline): ... this.

> --- a/local_atomic
> +++ b/local_atomic
> @@ -41,8 +41,7 @@
>  #ifndef _GLIBCXX_ATOMIC
>  #define _GLIBCXX_ATOMIC 1
>  
> -#undef  __always_inline
> -#define __always_inline __attribute__((always_inline))
> +#define __libitm_always_inline inline __attribute__((always_inline))

Why do you want to add inline keyword to that?  Some inline keywords
are implicit (methods defined inline), so there is no point adding it there.

	Jakub



More information about the Gcc-patches mailing list