[PATCH v4 1/2] Fix __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__

FX fxcoudert@gmail.com
Mon Sep 29 13:20:00 GMT 2014


Hi Mike,

I have not seen any trouble arising following the fix to PR 61407 (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61407). 
The patch committed is here: https://gcc.gnu.org/viewcvs?rev=215251&root=gcc&view=rev

I’ve just tested the exact same change on the 4.9 branch, and it bootstraps and regtests fine on x86_64-apple-darwin14 (I’ve got unrelated objc/obj-c++ failures, see PS).
I suggest we backport it to 4.9, so that when 4.9.2 is released it builds fine on Yosemite.

OK?

FX


PS: I’ve got quite a few objc/obj-c++ failures on x86_64-apple-darwin14, but I assume it’s because of changes in the Objective-C system headers… I’ve posted results here: https://gcc.gnu.org/ml/gcc-testresults/2014-09/msg02802.html
Nothing to do with parsing of Mac OS X versions, in any case.


More information about the Gcc-patches mailing list