[patch] rename DECL_ABSTRACT to DECL_ABSTRACT_P
Thu Sep 18 16:33:00 GMT 2014
On Thu, Sep 18, 2014 at 10:30:30AM -0600, Aldy Hernandez wrote:
> >>- DECL_ABSTRACT (fn) = 1;
> >>+ DECL_ABSTRACT_P (fn) = 1;
> >It'd probably make sense to use 'true' now.
> I thought about it, but I wanted to change as little as possible, plus I
> wanted to follow the same style as what we've been doing for a lot of the _P
> DECL_HAS_VALUE_EXPR_P (t) = 1;
> DECL_HAS_DEBUG_ARGS_P (from) = 1;
> DECL_IGNORED_P (lab) = 1;
> TREE_PUBLIC (decl) = 1;
> CONSTANT_POOL_ADDRESS_P (symbol) = 1;
> etc, etc.
> But I am happy to change it, if people feel strongly about it. (Though I'm
> not volunteering to change the other umteenhundred _P macros that currently
> use 0/1 ;-)).
Yeah, sure, either way it's a good cleanup ;).
More information about the Gcc-patches