[RFC][ARM] TARGET_ATOMIC_ASSIGN_EXPAND_FENV hook

Jay Foad jay.foad@gmail.com
Mon Jun 23 12:32:00 GMT 2014


On 2 May 2014 10:04, Kugan <kugan.vivekanandarajah@linaro.org> wrote:
> Thanks for spotting it. Here is the updated patch that changes it to
> ARM_FE_*.

> +2014-05-02  Kugan Vivekanandarajah  <kuganv@linaro.org>
> +
> +       * config/arm/arm.c (TARGET_ATOMIC_ASSIGN_EXPAND_FENV): New define.
> +       (arm_builtins) : Add ARM_BUILTIN_GET_FPSCR and ARM_BUILTIN_SET_FPSCR.
> +       (bdesc_2arg) : Add description for builtins __builtins_arm_set_fpscr
> +       and __builtins_arm_get_fpscr.

s/__builtins/__builtin/g

> +       (arm_init_builtins) : Initialize builtins __builtins_arm_set_fpscr and
> +       __builtins_arm_get_fpscr.

s/__builtins/__builtin/g

This doesn't match the code, which initializes builtins "...ldfscr"
and "...stfscr" (with no "p" in "fscr").

> +       (arm_expand_builtin) : Expand builtins __builtins_arm_set_fpscr and
> +       __builtins_arm_ldfpscr.

s/__builtins/__builtin/g

Did you mean "and __builtin_arm_get_fpscr"?

> +#define FP_BUILTIN(L, U) \
> +  {0, CODE_FOR_##L, "__builtin_arm_"#L, ARM_BUILTIN_##U, \
> +   UNKNOWN, 0},
> +
> +  FP_BUILTIN (set_fpscr, GET_FPSCR)
> +  FP_BUILTIN (get_fpscr, SET_FPSCR)
> +#undef FP_BUILTIN

This looks like a typo: you have mapped set->GET and get->SET.

Jay.



More information about the Gcc-patches mailing list